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Problem: License File Problems on Vista and Windows 7
Created: Monday, April 12, 2010
Updated: Tuesday, April 20, 2010
Article ID: KB743
Software involved: SLOPE/W 7.16, SEEP/W 7.16, SIGMA/W 7.16, QUAKE/W 7.16, TEMP/W 7.16, CTRAN/W 7.16, AIR/W 7.16, VADOSE/W 7.16,
Operating Systems involved: Windows 7, Windows Vista
Symptoms

Because of changes to file system permissions on Windows Vista and Windows 7 (more specifically, because of User Access Control, or UAC), GeoStudio 2007 users on these operating systems may have trouble updating license files.

There are several symptoms you may experience related to UAC and license files:

1. GeoStudio 2007 may be unable to automatically download new license files, instead displaying an error message such as:

    "License updates: A new license file is available but could not be installed automatically because you do not have permission to write to the Licenses folder (error AL102)."

2. If you manually download a license file from the geo-slope.com web site and save it to the default license folder (under C:\Program Files), it appears to save correctly but GeoStudio doesn't see it (and thus says you have no valid license).

3. If you use Tools License Management from the GeoStudio menu and change the license path, GeoStudio does not display any error message, but your change is not saved--next time you run GeoStudio it is still using the original license path.

Cause

All the symptoms listed above are related to the fact that UAC restricts your access to certain folders (such as Program Files) and to certain locations in the system registry, but often without displaying any warning or error.

Resolution

We recommend that users of Windows Vista and Windows 7 store their license files in a folder that is not protected by UAC, such as in the Program Data area of the file system.

The simplest way to do this is to use the License Migration tool available as a download from our web site.  Click here for further instructions and to download the License Migration tool.

Alternatively, you can make this change manually by moving your license files from their previous location (typically C:\Program Files\GEO-SLOPE\Licenses) to a new location (we recommend %ProgramData%\GEO-SLOPE\Licenses), then running GeoStudio 2007 as an administrator (see KB747) and selecting this new license file path under Tools License Management in the menu.

Status

These instructions ONLY apply to GeoStudio 2007 users running on Windows Vista or Windows 7.  Although users of other versions and users running on other operating systems may experience similar symptoms, they have different root causes, and therefore will likely not be resolved using the solution described here.

This Knowledge Base article will be updated if any new information becomes available.

Keywords
kb743 kbproblem win7 vista slope slopew slope7.16 slopew7.16 seep seepw seep7.16 seepw7.16 sigma sigmaw sigma7.16 sigmaw7.16 quake quakew quake7.16 quakew7.16 temp tempw temp7.16 tempw7.16 ctran ctranw ctran7.16 ctranw7.16 air airw air7.16 airw7.16 vadose vadosew vadose7.16 vadosew7.16
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